Welcome to nanos GbR

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

louij2

Server Won't announce to Masterlist

10 posts in this topic

Hi my server was on the master list before and then i changed a few settings and created a banner it then said the banner size is too big so i made the image smaller to 107kb and changed that and now it doesn't show failed or broadcasted to master list, the server is up and running and I can connect with ip: 109.168.10.83:4200

Share this post


Link to post
Share on other sites

So the masterlist package doesn't show anything? If that is the case try redownloading it and redoing the config: Could be that you did a small mistake there.

Share this post


Link to post
Share on other sites

Just did your steps no difference one problem is its not loading my steam anymore as I have a graphics problem with my linux system that I haven't been able to fix ever might have to do a whole system wipe if i can't fix it. To do with the Nvidia drivers, might just go ubuntu much easier

Share this post


Link to post
Share on other sites

Deleted Steam and installed SteamCMD, but server still doesn't show?

These are my startup logs

Quote

[email protected]:~/Desktop/JC3$ sudo ./Server
[sudo] password for server:
Loading Network Module
Initializing Network Module
Adding Directory client_packages, generating MD5 hashes. This might take a while.
Loading Scripting Module
Initialize Scripting Module
Read plugins
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 225540
Initialize Streamer Plugin
Initialize EntitySync Plugin
Initialize Game Plugin
Server successfully started up, awaiting connects...
Package 'chat' loaded.
Package 'command-hints' waiting for dependency 'command-manager'.
Command /help added to category 'help'
Package 'command-manager' loaded.
Package 'command-hints' loaded.
Package 'spawn-menu' loaded.
Package 'nanos-freeroam' loaded.
Loaded 4 package(s).
Adding virtual SubDirectory client_packages/chat.
4 files loaded from '/home/server/Desktop/JC3/packages/freeroam/events'.
Adding virtual SubDirectory client_packages/command-hints.
Adding virtual SubDirectory client_packages/spawn-menu.
Adding virtual SubDirectory client_packages/nanos-freeroam.
Command /kick added to category 'admin'
Command /ban added to category 'admin'
Command /admintpall added to category 'admin'
Command /m added to category 'admin'
Command /playerCount added to category 'admin'
Command /disarm added to category 'admin'
Command /netId added to category 'admin'
Command /creategroup added to category 'group'
Command /leavegroup added to category 'group'
Command /invitegroup added to category 'group'
Command /joingroup added to category 'group'
Command /group added to category 'group'
Command /suicide added to category 'player'
Command /passive added to category 'player'
Command /respawn added to category 'player'
Command /marker added to category 'teleport'
Command /teleport added to category 'teleport'
Command /goto added to category 'teleport'
Command /togglegoto added to category 'teleport'
Command /color added to category 'vehicle'
Command /localtime added to category 'world'
Command /weather added to category 'world'
Command /localweather added to category 'world'
Command /resettime added to category 'world'
Command /resetweather added to category 'world'
6 command files loaded.

 

 

Share this post


Link to post
Share on other sites

On your log, it doesn't look like your server loaded the masterlist. How is the masterlist package set up in the packages folder? It should be packages/masterlist-package/package.json.

If it's anything other than that, you didn't install it correctly.

Share this post


Link to post
Share on other sites

Yes this is wrong,

The Masterlist package has no client_package includet.

you have to copy the masterlist folder into your /jcmpserverroot/packages folder.

this looks like this /jcmpserverroot/packages/masterlist

and the masterlist folder have to contain the main.js

than it should load the package.

If than a error happens on loading, than you maybe forget to install the npm packages.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.